BASE DE CONNAISSANCES

Erreur "Unable to Sign In" et "Invalid username or password" avec SAML après la mise à niveau


Date de publication : 24 Dec 2018
Date de dernière modification : 24 Aug 2022

Problème

Après l'activation de SAML, accéder à la page Tableau Server entraîne l'affichage du message :

"Unable to Sign In - Invalid username or password". (Échec de la connexion. Nom d'utilisateur ou mot de passe non valide)

Environnement

  • Tableau Server 2018.3.1
  • SAML
  • Déchargement SSL via un proxy ou un équilibreur de charge

Résolution

Configurez le proxy ou l'équilibreur de charge pour définir l'en-tête X-FORWARDED-PROTO sur « https ».
Sinon, configurez SSL externe sur Tableau Server également pour un SSL direct complet.

Cause

Le code SAML vérifie alors que AuthNRequest accède au point de terminaison SAML attendu. Si le déchargement SSL est activé via un proxy, l'URL de retour utilisée pour SAML sera https://<url>. Par contre, à moins que l'en-tête X-FORWARDED-PROTO ne soit configuré, Tableau Server attendra un point de terminaison http://<url> étant donné que SSL externe ne sera pas configuré sur Tableau Server.
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