KNOWLEDGE BASE

Unable to refresh flows that is connected to ODBC Netsuite on Tableau Cloud


Published: 21 Nov 2022
Last Modified Date: 22 Nov 2022

Issue

Unable to refresh flows connected via ODBC Netsuite:

Failed to connect to the remote database server in connection NetSuite(ODBC)

Environment

  • Tableau Cloud
  • ODBC NetSuite

Resolution

As a workaround, please install Tableau Bridge on a dedicated machine and set up a refresh schedule for the ODBC NetSuite data source via Bridge. In order for Tableau Bridge to connect to the data source and keep the data fresh, the data source has to be separately published to Tableau Cloud.

1. Connect to a NetSuite data source in the latest version of Tableau Desktop. 
a. Go to https://www.tableau.com/support/drivers and find 'Oracle NetSuite' 
b. Download .jar file for Windows OS and move the downloaded .jar file to C:\Program Files\Tableau\Drivers.
c. Launch Tableau Desktop v2022.2 or higher and select the NetSuite connector.
d. Try connecting to the data source.  If the NetSuite connector does not work, please try the "Other Database(ODBC)" connector and test the connection again.
 
Once the connection is successfully made, move on to the next steps. 

2. Create an extract and publish it to Tableau Cloud.
a. Select the same table that is used for the flow.
b. Switch the radio button from Live to Extract on the top right corner. You will get prompted to save the extract. The location does not matter, so save it in the default location.
c. Move to 'Sheet 1' and select the Server menu.  Click Publish Data source.
d. In the Publish Data Source dialog box, select the Edit button and under Authentication, embed the password for the data source.
e. Click Publish.

3. Create a new extract refresh schedule for this published data source.
Once the publish process is complete, you will be automatically redirected to the published data source on  Tableau Cloud.
a. Select the Connections tab then click on ... and under Actions, select Edit connection.
b. For the Network type, select Private Network and save.
c. Go to the Extract refreshes tab and select the New Extract Refresh button to create a schedule.  Save the new schedule.  

4. Open the flow in Tableau Prep Builder and replace the original NetSuite input connection with a published NetSuite data source.
a. Click to add a connection.
b. Select Tableau Server and sign into your Tableau Cloud site if you are not signed in yet.
c. In the Search for Data dialog, find the published NetSuite data source in the list and then click the  Connect button.
d. Right-click on the original input, NetSuite and click Remove.
e. Drag the published data source input box and drop on the front end (Add) of the existing steps.

5. Republish the flow and output (as a published data source) in Prep Builder.

6. Try running the republished flow.
a. In Tableau Cloud, navigate to the newly published flow.
b. Click on Scheduled Task then select the New task button to create a schedule to run this flow.
c. Click ... and under Actions select Run Now.
d. Go to Jobs page to see the status of this job and check if it's successful

Cause

Connecting directly from Tableau Cloud to NetSuite is not currently supported.
Did this article resolve the issue?