KNOWLEDGE BASE

Unable to Pull Data from Child Directories in Hierarchies when Connecting Tableau to Salesforce Marketing Cloud


Published: 10 Jan 2024
Last Modified Date: 11 Jan 2024

Issue

The Salesforce Marketing Cloud (SFMC) connector is unable to pull data from child directories in hierarchies. 

Environment

  • Tableau Desktop
  • Tableau Server
  • Salesforce Marketing Cloud connector 

Resolution

As a potential workaround, create a separate connection in Tableau for each child directory in the hierarchy group from SFMC (such as Business Units) and join the connections.

Cause

The ability to connect to multiple hierarchies in a single Tableau connection to Salesforce Marketing Cloud (SFMC) is not built into the product.

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