Unable to Provision User E-mail Changes to Tableau Cloud Through Azure, Okta or OneLogin SCIM v2.0
Published: 27 Apr 2023 Last Modified Date: 24 Aug 2023
Issue
Unable to Provision user e-mail changes to Tableau Cloud through Azure, Okta or OneLogin SCIM v2.0.
Environment
Tableau Cloud
Azure
OneLogin
Okta
SCIM 2.0
Resolution
Workaround
Manually reassign the user in the IdP portal application for SCIM 2.0 and potentially remove the existing user in Tableau Cloud.
Note: If the user owns content then their content will need to be reassigned first. The easiest approach would be to just manually add the new user e-mail address to Tableau Cloud, move the content to the new e-mail address, and then delete the old e-mail address.
Cause
SCIM 2.0 does not have an automated way to support email address changes and provision the change to Tableau Cloud automatically.
Additional Information
Today, an email address is an immutable field in Tableau Cloud. When a user's e-mail address changes there is currently no way to update the existing Tableau Cloud user. Instead the user's new e-mail address must be added, any content they own transferred to the new e-mail address, and their old e-mail address deleted from Tableau Cloud.