KNOWLEDGE BASE

Unable to connect to Presto via JDBC on 2019.2 Tableau Desktop


Published: 22 Jul 2019
Last Modified Date: 24 Jul 2019

Issue

When attempting to make a connection to Presto via JDBC, you may get the following error:

"Bad Connection: Tableau could not connect to the data source.

No details available"


The below errors might be found in the Tableau Desktop logs.

  1. Log.txt
    • {"ts":"2019-07-19T07:16:26.711","pid":17636,"tid":"22b8","sev":"warn","req":"-","sess":"-","site":"-","user":"-","k":"compute-task-error","v":{"msg":"Starting the JVM failed.\n","stack":"disabled","task-name":"class ExternalProtocol::ConnectTask"}}
  2. tabprotosrv.txt
    • {"ts":"2019-07-19T07:16:26.326","pid":18196,"tid":"3d80","sev":"warn","req":"-","sess":"-","site":"-","user":"-","k":"compute-task-error","v":{"msg":"Starting the JVM failed.\n","stack":"disabled","task-name":"class `anonymous namespace'::ConstructProtocolTask"},"ctx":{"client-type":"desktop","procid":"17636","tid":"18896","version":"20192.19.0621.1547"}}
    • {"ts":"2019-07-19T07:16:26.326","pid":18196,"tid":"37c8","sev":"error","req":"-","sess":"-","site":"-","user":"-","k":"msg","e":{"log-code":"0e9ad54d","log-source":"needs-classification"},"v":"JVM::JVM Couldn't find symbol JNI_CreateJavaVM","ctx":{"client-type":"desktop","procid":"17636","tid":"18896","version":"20192.19.0621.1547"}}

Environment

  • Tableau Desktop 2019.2.2
  • Windows Server 2016

Cause

Java needs to be updated to the latest version.
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