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Unable to connect to Databases Using Mutual SSL


Published: 12 Nov 2018
Last Modified Date: 04 Jun 2019

Issue

Unable to connect to databases using mutual SSL because the check box "Enable SSL" in some connections does not prompt for client certificate and only does one-way authentication.

Environment

  • Tableau Desktop
  • Presto
  • Any native connection with the SSL enabled check box that does not prompt for cert file

Resolution

Use a TDC file must in order to accomplish mutual SSL authentication. See an example below: 
<?xml version='1.0' encoding='utf-8' ?>
<connection-customization class='presto' version='10.5' enabled='true'>
<vendor name='presto' />
<driver name='presto' />
<customizations>
<customization name='odbc-connect-string-extras' value='TRUSTEDCERTS=X:\XXXX.pem'/>
</customizations>
</connection-customization>

If the data source does not require SSL from the client machine, then the Enable SSL checkbox should work without a TDC file. However, please not that in most cases, this is not how the data source is set up and requires the client cert.


Important: Tableau does not test or support TDC files. These files should be used as a tool to explore or occasionally address issues with your data connection. Creating and maintaining TDC files requires careful manual editing, and there is no support for sharing these files.

Cause

This issue occurs because there is no built-in dual authentication for the "Enable SSL" checkbox.
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