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Unable to connect to Amazon Redshift when using customized driver parameter


Published: 07 Mar 2022
Last Modified Date: 07 Mar 2022

Issue

When connecting to Amazon Redshift with customized driver paramter, the following error might error

An error occurred while communicating with Amazon Redshift
Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database.
Error Code: 298A3F01
[Amazon][Amazon Redshift] (8600) Connection Error: : Encountered network error when sending http request (HTTP response code: 65535)
Unable to connect to the Amazon Redshift server "XXXX". Check that the server is running and that you have access privileges to the requested database.

Environment

  • Tableau Desktop 2021.4.1
  • Windows 10
  • Amazon Redshift

Resolution

1: Check whether a proxy server is used to access the Amazon Redshift database

2: Configure the https_proxy_host and https_proxy_port that proxy server uses in Enter custom driver parameters text box.

Cause

The proxy server is used to access Amazon Redshift. The proxy settings are not appended in the Amazon Redshift connector.
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