KNOWLEDGE BASE

Error "B19090E0 Two-Factor Authentication required" When Connecting to NetSuite


Published: 12 Oct 2021
Last Modified Date: 06 Aug 2022

Issue

When connecting to Oracle NetSuite with the connector in Tableau Desktop, it fails with the error:

Bad Connection: Tableau could not connect to the data source
Error Code: B19090E0

[USER_ERROR] Two-Factor Authentication required. 
Unable to connect to the NetSuite server "NetSuite". Check that the server is running and that you have access privileges to the requested database. 
Connector Class: cdata_netsuite. Version: 20.7923.0

Environment

  • Tableau Desktop
  • Oracle NetSuite

Resolution

Remove all roles that require 2FA from the account you're signing in with.

Cause

The Oracle NetSuite connector doesn't support two-factor authentication roles. 
Did this article resolve the issue?