KNOWLEDGE BASE

"tsm maintenance cleanup -a" Not Working as Expected when Tableau Server is Stopped


Published: 15 Sep 2022
Last Modified Date: 15 Sep 2022

Issue

Running tsm maintenance cleanup -a with the Tableau Server stopped and the Run As Service (RAS) is not in the local administrators group, results in users being unable to download/export content once the server is running again.

 

Environment

  • Tableau Server 2020.4 and newer
  • Windows Server 2016

Resolution

This issue has been resolved under ID 1422694 scheduled for a future release.

Workarounds:

  • Use "tsm pending-changes apply" before the tsm start.
  • Do not use "cleanup -a" or "cleanup -t" or "cleanup" without arguments.  Be sure to specify which other details need to be cleaned up using the exact command flags.
  • Reboot the hosts after cleanup and before the tsm start.

Cause

The cleanup command removes the Run As Service account from permissions on the Vizportal temp directory so that the gateway cannot access it.

Additional Information

  • Gateway's error.log has a line similar to the one below when the issue occurs:
    • [Mon May 02 17:14:58.xxxxxx 2022] [:error] [pid 28176:tid 9260] (OS 5)Access is denied.  : [client xx.51.55.xxx:xxxxx] xsendfile: cannot open file: E:/tableau/data/tabsvc/temp/vizportal_0.20213.22.0108.1051/xxxXXX.tdsx, referer: https://...
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