KNOWLEDGE BASE

TSM initialization window does not render in server-side web browser window


Published: 10 Aug 2018
Last Modified Date: 16 Oct 2019

Issue

During the Tableau Server 2018.2 Windows install process, when loading https://<servername>:8850 for the first time, the page does not render and install cannot continue.

Environment

  • Tableau Server 2018.2. and later versions.
  • Windows Server

Resolution

This issue can be caused by a couple of different reasons. Follow the below options for issue resolution:

Option 1

Ensure that the actual server https://<hostname> is in the "trusted sites" list (https://localhost is not sufficient, as the installer process will load the hostname by default).

Option 2

Use a supported browser other than Internet Explorer.

Option 3

All browsers (not just IE) are affected by browser-side caching. This issue might occur if another version of the server has previously been installed on the machine (in the case of an upgrade or obliterate + re-install). 

The resolution here is to hard refresh the page (in Chrome ctrl + shift + r). This blog post explains how to hard refresh in different browsers: How to do hard refresh in Crome, Firefox and IE.

Cause

Some configurations of Internet Explorer in Windows Server installs have Protected Mode enabled and are locked down in such a way that they will not load the TSM panel via the machine's hostname.
Did this article resolve the issue?