KNOWLEDGE BASE

TSM commands failing after rebooting the server host with "Could not connect to server. Make sure that Tableau Server is running and try again."


Published: 25 May 2021
Last Modified Date: 06 Aug 2021

Issue

On Oracle 7 Linux systems, when Tableau Server's host machine is rebooted after updating the FUSE library in the OS, TSM commands will fail with the following error:
 
"Could not connect to TSM Controller."
"Could not connect to server. Make sure that Tableau Server is running and try again." 

Tableau Server may eventually recover to a working state after some time. 

Environment

  • Tableau Server
  • Oracle Linux 7

Resolution

Perform a clean reinstall of Tableau Server, licensing included, and restore from a backup. 

As a potential workaround, to avoid restarting Tableau Server, try stopping/starting administrative services as this may help the services to start again (this only affects the license service's startup process): 

sudo systemctl daemon-reload
sudo /opt/tableau/tableau_server/packages/scripts.<version>/stop-administrative-services
sudo /opt/tableau/tableau_server/packages/scripts.<version>/start-administrative-services


To proactively avoid this issue, work with your internal IT department to ensure that the FUSE library is not updated on Tableau Server hosts.  

Cause

According to Flexera support, it is expected that Licensing issues will arise if the version of Fuse installed on a machine changes. Their instructions indicate a reinstall of the licensing process is necessary, but as we cannot do that standalone from Tableau Server, a clean reinstallation is the only option. 

Additional Information

To identify this issue:

1. Check the yum.log file (RHEL systems) or dpkg.log (Debian) to see if Fuse libraries have been updated since the install of Tableau Server.

Note: at this time, only Oracle Linux 7 systems have been found to be affected by this issue. See the Related Links on this page for other possible issues if this one is not a match.

2. Additionally, systemd logs (/var/log/messages or /var/log/syslog) will show FNP Licensing Service and TSM services repeatedly restarting:
 
Nov 09 14:50:20 o143006d systemd[5227]: Unit fnplicenseservice_0.service entered failed state.
Nov 09 14:50:20 o143006d systemd[5227]: fnplicenseservice_0.service failed.
Nov 09 14:50:20 o143006d systemd[5227]: fnplicenseservice_0.service holdoff time over, scheduling restart.
Nov 09 14:50:20 o143006d systemd[5227]: Stopped Tableau Server FNP Licensing Service.

In the same log, there will eventually be messages showing that FUSE has failed and exited:

Nov 09 14:50:20 o143006d FlexNetFs[19593]: Entering fuse_main
Nov 09 14:50:20 o143006d FlexNetFs[19593]: Exited fuse_main - Failed


Tableau Server Unlicensed After an OS Reboot
Tableau Server License Service on Linux Cannot Read License after Restart

Did this article resolve the issue?