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Error "Timeout Error: IPC_NamedPipe::Select(WaitForMultipleObjects)" Connecting to Data or Working with Extracts


Published: 06 Feb 2018
Last Modified Date: 29 Oct 2019

Issue

When attempting to connect to a data source, or create and/or refresh extracts with Tableau Desktop, the following error message occurs:
 
 IPC_NamedPipe::Select(WaitForMultipleObjects): Timeout.

Environment

  • Tableau Desktop 

Resolution

Option 1:

Work with IT to add Tableau folders and processes to exclusions:
  • Tableau.exe
  • hyperd.exe
  • hyperdstarter.exe
  • *.hyper extension (if AntiVirus has an option for extension exclusions)
  • C:\Users\<username>\Documents\My Tableau Repository
  • C:\Users\<username>\AppData\Local\Temp\TableauTemp
  • C:\Users\<username>\AppData\Local\Tableau
  • C:\Program Files\Tableau
    • Make sure that child folders are included in the exclusions. AntiVirus programs may have different options to do this unique to the program, such as using wildcards in the path (*), or an explicit option to add child folders.
Note: The paths above are based on a default installation of Tableau Desktop. If Tableau Desktop was installed in a non-default location, and/or the My Tableau Repository folder was redefined, please make sure that the exclusions match the corresponding paths of the non-default installation.

To help make sure these exclusions are set for full coverage and take effect:
  1. Include the above paths and programs in exclusions for all scan settings, and if the AntiVirus has a list specifically for "Trusted Programs", add the .exe files there.
  2. Reboot the affected machine.

Option 2:

  1. Close Tableau Desktop.
  2. Navigate to your My Tableau Repository and rename the Logs folder to Logs_Backup. 
  3. Re-open Tableau Desktop.

Option 3:

  1. Close Tableau Desktop.
  2. Change the Tableau Desktop Repository location from a network drive to the local disk on Tableau Desktop machine.
  3. Re-open Tableau Desktop.

Cause

Anti-virus software is blocking Tableau processes from running, or the Logs folder contained corrupted information, or Tableau Desktop Repository location is not on local disk.

Additional Information

Check the C:\Users\<username>\Documents\My Tableau Repository\Logs folder to see if a "hyperd.log" file was created. If the file is not present, this indicates the anti-virus software may be blocking the startup of the hyper process, which is specific to Tableau Desktop 10.5 and higher.


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