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Tableau Desktop hangs for a long time when try to connect to Salesforce and finally ends with the error 'Error Code:0E9BCD3C'


Published: 04 Apr 2023
Last Modified Date: 05 Apr 2023

Issue

When choose Salesforce within Tableau Desktop to make connection, it just hangs for a long time, and then ends with the error.

"Error starting OAuth Server, process exited. Exit code. Exit status:0.  Error code: 5. Check C:\Users\XXXXXX\Documents\My Tableau
 Repository\Logs\stdout_oauthservice.txt for details.
 Error Code:0E9BCD3C"


The following message shows in 'stdout_oauthservice.txt':
Picked up _JAVA_OPTIONS: -Djavax.net.ssl.trustStoreType=Windows-ROOT
WARNING: sun.reflect.Reflection.getCallerClass is not supported. This will impact performance.
OAuthProviderService started, listening on 56979.
Mar. 01, 2023 12:19:46 PM io.grpc.internal.ServerCallImpl internalClose
WARNING: Cancelling the stream with status Status{code=INTERNAL, description=Completed without a response, cause=null}

Environment

  • Tableau Desktop
  • Salesforce

Resolution

Tableau leverages the various force.com APIs to connect to Salesforce.com, Force.com, and Database.com data.

In order for Tableau to connect to Salesforce data, all of the following must be enabled on both the company's account and the user profile:

  • SOAP API for signing in

  • REST API for getting meta data

  • BULK API for downloading objects

  • REST API for downloading objects that the BULK API does not support

  • Replication SOAP APIs for retrieving changes in the data

Cause

Certain Salesforce API is not enabled under the Company account and user profile.
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