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Tableau Desktop connecting to Tableau Server gives SSL certificate error with SAML login


Published: 30 Aug 2019
Last Modified Date: 06 Sep 2019

Issue

When connecting to Tableau Server from Tableau Desktop, the following error message appears:

Cannot connect to Tableau Server. Please check the server name and port and try again.
The host name did not match any of the valid hosts for this certificate
The certificate is self-signed, and untrusted


Despite not having SSL configured on Tableau Server (and with no proxy or load balancer) an SSL certificate validation error occurs when connecting to Tableau Server. Users will be able to connect to Tableau Server normally in a web browser.

However, when using Tableau Desktop, the error message will appear when the SAML authentication window attempts to load and will not allow the user to proceed.

Environment

  • Tableau Desktop
  • Tableau Server without SSL 
  • SAML authentication with self-signed or otherwise invalid SSL certificate

Resolution

Correct or replace the invalid SSL certificate in the SAML IdP web portal.

Cause

Tableau Desktop evaluates the SSL certificate when opening a portal to the SAML IdP and reports that the certificate has failed validation rather than continuing to the page. This can happen if the IdP is hosted in-house with a self-signed certificate that is managed through group policy by the customer's IT team. 

Additional Information

Occasionally, you may want Tableau Desktop to connect to Tableau Server without authenticating via SAML. If that is the case, check the  "wgserver.authentication.desktop_nosaml".
If the value of this is "false", set it to "true".

In pre-2018.2 Windows use these commands:
  • tabadmin set wgserver.authentication.desktop_nosaml true
  • tabadmin config
  • tabadmin restart
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