Tableau Desktop Closes Unexpectedly on Mac with Hive Based Connections
Published: 20 Mar 2018 Last Modified Date: 17 Nov 2019
Issue
Tableau Desktop may unexpectedly quit upon opening, selecting 'Save As' and/or creating an extract when using Hive based data source on the Mac.
You may notice that performance lag may also occur when using the tool bar.
Environment
Tableau Desktop 10.4.0 - 10.4.6, 10.5.0 - 10.5.2
Mac OSX
Hortonworks Hadoop Hive
MapR Hadoop Hive
Spark SQL
Cloudera Hadoop
Microsoft Azure SQL
Resolution
Upgrade to Tableau Desktop 10.5.3, 10.4.6 or a later version. For more information, see Upgrading Tableau Desktop in Tableau Help.
Cause
Stability issues occurred where Tableau was unable to determine the driver version from the driver name with Hive based data sources. Additionally, this behavior is related to a known issue (ID: 740687) which has been fixed in a recent release of Tableau Desktop.
Additional Information
During extract issue, the following error appears in the tabprotosrv.txt log file:
Exception: ReadBytes: Communication with the Tableau client process was lost.