KNOWLEDGE BASE

Tableau Bridge WDC Extract Refresh Jobs Failing After Upgrading to Version 2023.1


Published: 02 Jun 2023
Last Modified Date: 05 Jun 2023

Issue

After upgrading Tableau Bridge to 20231.23.0511.1508 (released in May 2023), WDC extract refresh jobs executed on Bridge may fail with an error about URLs not being recognized or present in the secondary allow list found in the Tableau Bridge logs.

Environment

  • Tableau Bridge 2023.1
  • Web Data Connector (WDC)

Resolution

The following workaround options are available:

1. Revert back to the previous working version of Tableau Bridge.
2. Use Tableau Desktop to refresh the extract and republish it to Tableau Cloud.

Cause

WDC URLs are not present in the secondary allow list. This issue is currently under investigation under Known Issue W-13523602 published on the Salesforce Known Issue website.  

Additional Information

This issue can be identified using Tableau Bridge logs, specifically the tabprotosrv log, for the following messaging at the time of the failure:

{"ts":"2023-05-21T23:46:27.170","pid":8528,"tid":"2120","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"web-data-connector","v":"Secondary whitelisting: does not find a corresponding entry for URL '<url>', hence it is not allowed","ctx":{"client-procid":"9868","client-tid":"5716","client-type":"desktop","client-version":"20231.23.0511.1508"}}
{"ts":"2023-05-21T23:46:27.170","pid":8528,"tid":"2120","sev":"error","req":"-","sess":"-","site":"-","user":"-","k":"msg","e":{"excp-error-code":"0x2CEE0515","excp-source":"NeedsClassification","excp-status-code":"UNKNOWN"},"v":"Web data connector secondaryWhitelist failed request for url <url>'; ask your Tableau server admin to enable this url in the secondary whitelist.","ctx":{"client-procid":"9868","client-tid":"5716","client-type":"desktop","client-version":"20231.23.0511.1508"}}

 
Tableau Bridge logs can be found in  /Users/<username>/Documents/My Tableau Bridge Repository.
Did this article resolve the issue?