Tableau Bridge Status is Disconnected and Data Source List Doesn't Populate After Upgrading
Published: 19 Oct 2018 Last Modified Date: 01 Jun 2020
Issue
When running Tableau Bridge 2018.2 in Application mode and upgrading to any newer release of the client, the following issues occur in the Tableau Bridge UI:
Status shows Disconnected
The list of data sources does not populate
Example:
Environment
Tableau Bridge 2018.2 - 2018.3
Application Mode
Resolution
To prevent this issue from occurring, fully exit Tableau Bridge 2018.2 prior to running the 2018.3 or newer installer.
To resolve the issue if it has already occurred:
Exit Tableau Bridge by clicking the Settings icon and choosing exit, or by right-clicking the icon in the system tray and choosing exit.
Open Windows Task Manager, locate the process "TabBridgeClientWorker.exe", and end the process.
Run the Tableau Bridge 2018.3 or newer installer again.
Cause
This behavior is related to a known issue with ID 836601 which prevented Tableau Bridge 2018.2 from fully exiting during upgrade, and has been corrected in newer versions of Tableau Bridge.
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