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Tableau Bridge Disconnecting Intermittently with "Operation timed out" Error in Logs


Published: 16 May 2023
Last Modified Date: 29 May 2023

Issue

A Tableau Bridge client may become intermittently disconnected from Tableau Cloud.

Additionally, the following error may be found in the TabBridgeClientWorker_svc log files:

Failed to create the Workgroup connection due to the following error: Failed to connect to server: https://online.tableau.com due to the following error: Operation timed out.

Environment

  • Tableau Bridge
  • Tableau Cloud

Resolution

Try increasing the connectTimeout value in TabBridgeClientConfiguration.txt:
  1. On the machine where the Tableau Bridge client is installed, go to the Configuration folder in the My Tableau Bridge Repository. The default location of the Configuration folder is C:\Users\<user>\Documents\My Tableau Bridge Repository\Configuration.
  2. Open the TabBridgeClientConfiguration.txt file in a text editor.
  3. Next to connectTimeout, change the value to 5.
  4. Save and close the file.
  5. Exit the client for the changes to take effect. The way you exit the client depends on whether the client is running in Application or Service mode.
    For Application mode: from the client menu, select Exit.
    For Service mode: from the client menu, select Exit. In the dialog box, select the 'Exit client and stop activities' check box and click Close.
  6. Restart the client for the changes to take effect.

Cause

There may be a network connectivity issue with the computer running Tableau Bridge. 
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