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SQL Server extract fails to be refreshed by schedule via Tableau Bridge client


Published: 04 Feb 2024
Last Modified Date: 05 Feb 2024

Issue

SQL Server extract fails to be refreshed by schedule via Tableau Bridge client with the following error:

The following error could be found in Site Status/Admin View 'Bridge Extracts':

Failure   Refresh Data Source Extract         2/1/2024 11:15:06 AM  <DataSourceName>               <Tableau bridge CLientName>              Refresh Data Source Extract         2/1/2024 4:15:06 PM    status code = 5049, Failed to refresh data source: <DataSourceName> due to the following error: [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]Login failed for user 'Domain/UserName'.
Integrated authentication failed.

                status code = 5049          1,000    1.00000               1             -0.208333

Environment

  • Tableau Cloud
  • Windows Authentication
  • SQL Server

Resolution

1. Verifiy the Windows Authentication is used in SQL server. 
2. Using Tableau Desktop, re-connect to the data source via Windows Authentication, then re-publish the extract.

Cause

Windows Authentication is used to connect to database Microsoft SQL Server and the user login credential (e.g. password) has been modified which caused the connection failure. 
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