KNOWLEDGE BASE

Snowflake Measures Not Appearing in View


Published: 04 Jul 2018
Last Modified Date: 09 Jul 2018

Issue

When some measures from a Snowflake data source are added to a view in Tableau Desktop, the values for these measures may not appear. The underlying data may show values or it may show Null.

Environment

  • Tableau Desktop
  • Snowflake

Resolution

Option 1

  1. Open the affected workbook in Tableau Desktop.
  2. Select the Data Source tab.
  3. Right-click the Snowflake connection on the left panel and select Initial SQL....
  4. In the Initial SQL dialog box, enter the following statement:
    ALTER SESSION SET QUOTED_IDENTIFIERS_IGNORE_CASE = FALSE
  5. Click OK.

Option 2

Alternatively, work with your Snowflake administrator to set the QUOTED_IDENTIFIERS_IGNORE_CASE parameter to FALSE globally for the data source.

Cause

Tableau uses double quotes for identifiers in the underlying SQL queries, which may result in queries containing identifiers that cannot be found in Snowflake due to differences in case.
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