KNOWLEDGE BASE

Slow Connecting to Snowflake


Published: 20 Apr 2023
Last Modified Date: 21 Apr 2023

Issue

The time taken for Tableau to connect to a Snowflake data warehouse may be longer than expected. For example, after clicking Sign In, the Processing Request (Executing query) dialog box may be displayed for a few minutes, before the data source page appears.

Environment

  • Tableau Desktop
  • Snowflake

Resolution

Work with your network administrator to verify whether your computer can connect to the Snowflake OCSP cache server on port 80.

Cause

A possible reason is that the Tableau Desktop computer is not able to reach the Snowflake OCSP cache server on port 80. The Snowflake ODBC driver waits for a response from the OCSP cache server, and this waiting period times out before the rest of the connection process can take place.

Additional Information

For more information about configuring connectivity to Snowflake’s OCSP response cache server, see the following Snowflake documentation: Disclaimer: The above links take you outside of Tableau.com. Although we make every effort to ensure links to external websites are accurate, up to date, and relevant, Tableau cannot take responsibility for the accuracy or freshness of pages maintained by external providers. Contact the external site for answers to questions regarding its content.
Did this article resolve the issue?