KNOWLEDGE BASE

Server Error Occurs In TSM Web UI When Activating Tableau Server Using The Authorization-To-Run (ATR) Service on Windows


Published: 19 Dec 2021
Last Modified Date: 21 Dec 2021

Issue

Server Error occurs in TSM Web UI when activating Tableau Server using the Authorization-To-Run (ATR) Service.

Server Error
The server encountered an unexpected error processing the request. Look at the server logs for more information.


After running "tsm licenses activate --license-key <product key>" instead, the following error can be found in tsm.log:

ERROR com.tableausoftware.tabadmin.TSMErrorHandler - An error occurred: 500000, Internal Server Error
ERROR com.tableausoftware.tabadmin.cli.Console - Internal Server Error: The server encountered an unexpected error processing the request. Look at the server logs for more information.

 

Environment

  • Tableau Server
  • Windows Server
  • Forward Proxy

Cause

To access and subsequently configure product key information for Tableau Server installation, the Windows service, Tableau Server Administrative Controller, must run under the Run As service account.

Additional Information

The following message may be recorded in the log.

Example:
ziplogs\tabadmincontroller_0.20213.21.1112.143413223401664649809205\logs\tabadmincontroller_node1-0.log
2021-12-13 17:44:42.905 +0900  qtp1152429864-1433 : INFO  com.tableausoftware.tabadmin.webapp.impl.ProductKeyService - Activating license
2021-12-13 17:44:42.905 +0900  qtp1152429864-1433 : DEBUG com.tableausoftware.domain.licensing.InitializeNativeThreadSupplier - Initializing verifier foreground thread.
...
2021-12-13 17:45:33.578 +0900  qtp1152429864-1433 : ERROR com.tableausoftware.tabadmin.webapp.GlobalExceptionHandler - TableauException
com.tableausoftware.license.dll.TableauException: Operation timed out.


ziplogs\tabadmincontroller_0.20213.21.1112.143413223401664649809205\logs\nativeapi_tabadmincontroller_node1-0_2021_12_13_00_00_00.txt
{"ts":"2021-12-13T17:44:42.920","pid":10872,"tid":"3788","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"InitializeForegroundThread: 6de76dec5c828a40"}
{"ts":"2021-12-13T17:44:42.920","pid":10872,"tid":"3788","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"BEGIN Verifier::Activate for SerialNumber TSXX-XXXX-XXXX-XXXX-XXXX"}
...
{"ts":"2021-12-13T17:45:33.578","pid":10872,"tid":"3010","sev":"warn","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"Request for 'https://atr.licensing.tableau.com:443/server/getAtrForServer' failed."}

 
For more information, see:
Did this article resolve the issue?