KNOWLEDGE BASE

Schema Section Does Not Load When Connecting to Amazon Redshift


Published: 10 Oct 2023
Last Modified Date: 10 Oct 2023

Issue

When connecting Tableau Desktop to an Amazon Redshift database, the Schema section may not load on the Data Source page.

Environment

  • Tableau Desktop
  • Windows
  • Amazon Redshift

Resolution

  1. Uninstall Amazon Redshift ODBC Driver version 2x (for example 2.0.0.1).
  2. Install the 64-bit ODBC driver version 1x (for example 1.5.7) from this Amazon Redshift page.

Cause

Tableau only supports the 1x driver versions with the Amazon Redshift connector.
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