KNOWLEDGE BASE

Scheduled subscriptions are failing with below error: ErrorCode: 150024 SUBSCRIPTION_UNKNOWN_ERROR. For input string: "true"


Published: 11 Jun 2023
Last Modified Date: 15 Jun 2023

Issue

Scheduled subscriptions are failing with the error below:

SubscriptionErrorResult: ErrorCode: 150024; Error Category: UNKNOWN; Error message: SUBSCRIPTION_UNKNOWN_ERROR. For input string: "true";Internal Server Error

    Environment

    • Tableau Server 2022.3.1
    • CentOS 7
    • MS Exchange

    Resolution

    Run the following tsm command on Tableau Server to verify the value set for "subscriptions.max_attachment_size_megabytes" (Default value is 150 (in MB)). 

    • tsm configuration get -k subscriptions.max_attachment_size_megabytes (It will give the current value set for the 'subscriptions.max_attachment_size_megabytes' parameter, if it is set to 'true' then run following commands)
    • tsm configuration set -k subscriptions.max_attachment_size_megabytes -v 150
    • tsm pending-changes apply (you must run this command, it will require a Tableau server restart, command will display a prompt to let you know a restart will occur)

    Once the Tableau server is up & running again, please run a subscription manually and verify if the emails are now triggering correctly.

    Cause

    By mistake, the boolean value (true) was set but it should be a numerical value for subscriptions.max_attachment_size_megabytes.

     
    Did this article resolve the issue?