Published: 20 Dec 2019 Last Modified Date: 08 Jul 2022
Issue
Run Now button is missing when trying to run a manual refresh in Tableau Bridge.
Environment
Tableau Bridge
Resolution
The most common cause of the "Run Now" button not appearing is that another Tableau Bridge data source is refreshing at the same time. There are two ways to verify this:
Option 1: Using the Tableau Bridge Taskbar Icon
Go to the taskbar and select the ^ icon and a popup should appear showing several icons
Observe the Tableau Bridge icon
If the Tableau Bridge icon shows a green symbol such as this means that another refresh is currently running
When the Tableau Bridge icon no longer shows a green symbol such as , it should now be possible to perform a "Run Now" refresh
Option 2: Using the Tableau Bridge Data Source List
Go to the taskbar and select the ^ icon and a popup should appear showing several icons
Select the Tableau Bridge icon and the Tableau Bridge screen should display showing a list of data sources within Tableau Bridge
Scroll through the data sources, if any of them display a spinning icon with a time value such as this means that they are currently running and a "Run Now" refresh is not possible
If you have confirmed that a refresh is currently running you can choose to cancel the running refresh by selecting the "x" beside the spinning icon or wait for the refresh to complete. It should then be possible to perform a "Run Now" refresh
Cause
Tableau Bridge refreshes run serially and it is not possible to queue a run now refresh job.
Thank you for providing your feedback on the effectiveness of the article.