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Error "Request session id does not match dataserver session id" Error Code: C40B391C


Published: 21 Jul 2021
Last Modified Date: 24 Aug 2023

Issue

When opening a workbook connected to published data sources, intermittently the following error might occur:

Error Code: C40B391C

Request session id does not match dataserver session id
DataServiceFailure
Unable to properly calculated the domain for the field. Display data may be incorrect.

Environment

  • Tableau Desktop
  • Tableau Server
  • Tableau Cloud

Resolution

There have been a number of solutions to this issue, listed here in order of likelihood of success based on case reviews:

I. Re-Creating the Tableau Desktop Repository

  1. Ensure all instances of Tableau Desktop are closed
  2. Navigate to the existing Repository location. Most often, this will be .../My Documents/My Tableau Repository
  3. Rename the existing Repository to "My Tableau Repository.old"
  4. Open Tableau Desktop again - a new Repository should be created automatically
  5. Attempt to open the affected workbook once again
 

II. Ensure Parity between Tableau Desktop and Tableau Server/Cloud Versions

  1. Review the installed versions of Tableau Desktop and Tableau Server/Cloud
  2. If Tableau Desktop is a different version than Tableau Server/Cloud, please update Tableau Desktop to the closest matching Server/Cloud version.  Tableau Release versions and downloads are available on our website here
  3. Republish the affected workbook/datasource from the updated Tableau Desktop version and see if the issue persists
 

III. Re-Create the Affected Workbook

  1. If the previous methods did not resolve the issue, try to re-create the affected workbook while ensuring parity between Desktop and Server/Cloud versions, and that the repository has been re-created in a suitable location
  2. Republish the recreated workbook/datasource 
 

IV. Review Proxy Settings

If using a Proxy in the environment, please work with your IT team ensure it is configured properly to allow unobstructed traffic from Tableau applications. These settings and recommendations can be reviewed in the following articles:
Required Addresses, Proxies, and Ports
Configuring Proxies for Tableau Server

Cause

The issue may be related to a network issue between Tableau Desktop and Tableau Server/Tableau Cloud or the need to recreate the My Tableau Repository folder.
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