KNOWLEDGE BASE

Repeated Reconnect Prompts When Connected to Impala


Published: 28 Mar 2019
Last Modified Date: 21 Oct 2019

Issue

When connected to Cloudera Hadoop Impala, a reconnect message may appear every 5 to 10 minutes. For example:

Reconnect to federated.0ljz6ic0kor8k21axpx9z0k7z5x7?

Occasionally when reconnecting, another error may occur, which goes away after a few refresh attempts:

[Cloudera][ImpalaODBC] (110) Error while executing a query in Impala: [] :

Environment

  • Tableau Desktop
  • Cloudera Hadoop Hive

Resolution

If the Kerberos authentication method is not used, customize the Impala connection using a .tdc file:
  1. Close all Tableau Desktop windows
  2. Save the attached .tdc file to Documents\My Tableau Repository\Datasources

Cause

AutoReconnect is disabled by default for Cloudera Hadoop Impala connections, because having this option enabled is not compatible with Impala connections using the Kerberos authentication method.
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