知识库

升级 Tableau Desktop 后刷新数据提取时出现 Tableau Bridge 错误


发布时间: 21 Jan 2016
上次修改日期: 21 Oct 2019

问题

在升级 Tableau Desktop 以与 Tableau Online 版本匹配后,Tableau Bridge(同步客户端)未能刷新数据提取并出现以下错误:

“无法刷新数据源。如果此问题仍然存在,请与 Tableau 联系...”
“此数据源的用户名或密码不正确。确认您是否具有相应的权限并重新输入凭据”
“尝试加载数据源 <> 时出错。加载无法成功完成。此文件由较新版本的 Tableau 创建。请与 Tableau Software 联系以升级到您的版本。”

环境

  • Tableau Bridge(以前称为同步客户端)
  • Tableau Desktop
  • Tableau Online

解决方案

请尝试以下解决方法选项:

选项 1

禁用、退出并重新启动 Tableau Bridge(同步客户端)
  1. 如果 Tableau Bridge 以服务形式运行(连续运行),请选择 Bridge 菜单按钮,并选择“仅在登录时运行”
  2. 选择 Tableau Bridge 菜单,并选择“退出”
  3. 从最新 Tableau Desktop 版本中重新启动 Tableau Bridge。
  4. 如果愿意,请重新启用“连续运行”模式。


选项 2 

取消链接并重新配置 Tableau Bridge(同步客户端)
  1. 右键单击 Tableau Bridge 任务栏图标。
  2. 单击“取消链接 Tableau Bridge”(同步客户端)。
  3. 右键单击 Tableau Bridge 任务栏图标,并选择“注销”
  4. 打开 Tableau Desktop 的新版本。
  5. 单击“服务器”>“启动 Tableau Bridge”(同步客户端)。
  6. 将数据源重新配置为使用 Tableau Bridge(同步客户端)进行刷新。

原因

在运行 Bridge(同步客户端)期间安装 Tableau Desktop 的新主要版本时(例如使用 9.0 版本并安装 9.1 版本)会出现此问题。如果未取消链接 Bridge(同步客户端),则它会在计算机重启后重新启动错误的客户端版本。

其他信息

验证正在运行的 Tableau Bridge(同步客户端)的版本:
  1. 登录到运行 Tableau Bridge(同步客户端)的计算机。
  2. 打开“任务管理器”窗口。
  3. 单击“进程”选项卡。
  4. 右键单击“TabOnlineSyncClient.exe”并选择“属性”
“常规”选项卡将显示文件位置,以标识正在运行的 Tableau Bridge(同步客户端)版本。“详细信息”选项卡将显示正在使用的特定文件版本以进行更深入的分析。
此文章是否已解决问题?