KNOWLEDGE BASE

OneDrive Connector Retired and Flows Fail to Connect or Refresh with Error "Tableau Doesn't recognize the data source type 'cloudfile:onedrive-excel-direct'"


Published: 30 May 2023
Last Modified Date: 01 Jun 2023

Issue

Existing workbooks, data sources, and flows fail to connect or refresh and the following error message occurs:
 
Tableau doesn't recognize the data source type 'cloudfile:onedrive-excel-direct'. It might not be available in this version of Tableau, or it might be a connector plugin that's not installed on this system.

Environment

Tableau Cloud
Tableau Desktop 2023.2
Tableau Prep Builder 2023.2

Resolution

Open the existing workbook, data source, or flow in a pre-2023.2 version of Tableau Desktop or Tableau Prep Builder and perform the steps below to replace data sources. This may require downloading your existing workbook, data source, or flow from Tableau Cloud if that is where they are published.

Tableau Desktop

1. Open your workbook or data source.
2. Add a new data source (Data > New Data Source) and select the OneDrive and SharePoint Online connector.
3. Connect to the same file being used in the existing workbook or data source.
4. Replace data sources (Data > Replace Data Source).
5. Close the original data source based on the removed OneDrive connector.
6. Save and republish your workbook or data source.

Tableau Prep Builder

1. Open your flow.
2. Add a new connection using the OneDrive and SharePoint Online connector.
3. Connect to the same file being used in the existing flow.
4. Replace the original input node(s) with the same ones from the OneDrive and SharePoint Online connector.
5. Remove the original OneDrive (deprecated) connection.
6. Save and republish your flow.

Cause

The OneDrive connector, which was deprecated in Tableau 2022.2, is being retired and was removed in Tableau 2023.2.

See the Tableau Knowledge article on the OneDrive connector being deprecated in 2022.2.
Did this article resolve the issue?