KNOWLEDGE BASE

"No IDP was configured, please update included metadata with at least one IDP" error was found after configuring SAML SSO


Published: 28 Apr 2021
Last Modified Date: 10 May 2021

Issue

After configuring SAML, users failed to log in and saw "Invalid username or password, Try Again"
In Tableau Server logs(vizportal_node# or tomcat_vizportal_node#) the following error message was found :
"No IDP was configured, please update included metadata with at least one IDP"

Environment

  • Tableau Server 
  • SAML SSO

Resolution

 
Work with your IdP administrator to verify that the IdP metadata xml file is properly formatted.
Once it's regenerated, please follow the steps to complete reconfiguration on TSM :
1. Re-exchange metadata.xml between Tableau Server and IdP
  • Download a new metadata.xml from TSM and upload it to IdP (Step 2 - Step 3)
  • Upload the newly generated IdP's metadata.xml to TSM (Step 4)
2. Click 'Save pending changes' > Click 'Pending changes' on top of the page > Click 'Apply changes and Restart'
*Applying pending changes will cause Tableau Server restart. 

Cause

The issue was caused by the IdP metadata xml file which was not properly formatted.
One of the scenarios, if unsupported character(ex. '-') is included, it will prevent Tableau Server from identifying required information of IdP.
-<EntityDescriptor xmlns="urn:oasis:names:tc:SAML:2.0:metadata" entityID="ENTITYID" ID="ID">
-<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">;
-<SignedInfo>
-<Reference URI="#">
-<Transforms>
-<KeyInfo>
-<X509Data>
.
.
.
Did this article resolve the issue?