KNOWLEDGE BASE

Maps Do Not Display After Configuring Firewall Rules


Published: 07 Aug 2019
Last Modified Date: 04 May 2020

Issue

After whitelisting mapsconfig.tableau.com and restricting traffic to HTTPS, maps do not render. 

 

Environment

  • Tableau Server 2019.2.0 - 2019.2.2, 2019.3.0
  • Tableau Desktop 2019.2 - 2019.2.2, 2019.3.0

Resolution

Option 1:

Upgrade to Tableau Server or Tableau Desktop version 2019.2.3, 2019.3.1 or later
Click here for downloads of current and previous versions of Tableau Server: Tableau Server Downloads and Release Notes. For more information on current releases, see Upgrade Tableau Server and Server Upgrade.
 Click here for downloads of current and previous versions of Tableau Desktop: Tableau Desktop Downloads and Release Notes.  For more information on current releases, see Upgrade Tableau Desktop and Desktop Upgrade.

Option 2:

If you cannot upgrade, try the following workaround for Tableau Server:
Amend :443 to the end of https://mapsconfig.tableau.com in the Tableau.tms file, located under: <Install Drive>\Tableau Server\packages\vizqlserver.<build number>\mapsources

For example:
<connection class="MapboxVector" data-url="v4" offline="" params-url="https://mapsconfig.tableau.com:443/v1/config.json" port="443" server="https://api.mapbox.com" url="styles/v1"/>

Cause

This behavior was caused by known issue, ID 948005, which has been resolved starting with version 2019.2.3 and 2019.3.1.

Additional Information

  • Testing connectivity via browser to mapsconfig.tableau.com will return a 403 Forbidden error as a result of this issue.
  • As a result of this issue, you may notice requests to mapsconfig.tableau.com being sent as HTTP rather than HTTPS. 



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