KNOWLEDGE BASE

Logs Sent Using "tsm maintenance send-logs" or the Upload to Technical Support Option in TSM Do Not Get Sent to Tableau


Published: 26 May 2023
Last Modified Date: 26 Sep 2023

Issue

In Tableau Server 2022.3 and newer, logs sent using the "tsm maintenance send-logs" command, or the "Upload to Technical Support" button in the TSM Web UI, are not sent to the Tableau Support case as expected.  

There are no errors in TSM and the job shows as succeeding.

Environment

  • Tableau Server 2022.3 and above

Resolution

Option A

If you have already run the send-logs command, you may supply some additional telemetry to Tableau Support to allow manual retrieval of the logset.  On the node where the tabadmincontroller process is running (typically node1), retrieve the log file under $TABLEAUSERVERDATADIR\data\tabsvc\logs\clustercontroller\tabcrashreporter\tabcrashreporter.txt where $TABLEAUSERVERDATADIR is one of:

WINDOWS: D:\ProgramData\Tableau\Tableau Server\
LINUX: /var/opt/tableau/tableau_server/
OR a custom path defined at installation.

You may either provide this file as-is to Tableau Support, or provide the issue-ID that was logged when you performed the send-logs command.  The relevant logging will look like: 

"issue-id\":\"3a82669c-f3cd-4b36-a9f5-ee5956f91bef\"

Option B

Change the features.RemoveDoubleEncryption key to be "false".  Note that applying this change will require a restart of Tableau Server.

1. Run: tsm configuration set -k features.RemoveDoubleEncryption -v false
2. Run: tsm pending-changes list
3. After confirming that the change to features.RemoveDoubleEncryption is the only change pending, run tsm pending-changes apply

After changing this setting, logs should start showing up in support cases again.

Option C

Run the send-logs command manually with the RemoveDoubleEncryption flag disabled.  This option is considerably more complicated but does not require a Tableau Server restart.

1. Run: tsm maintenance send-logs -f <log file location> -e <email> -c <case number>
2. Search through the tabadmincontroller_node#-#.log file for the equivalent tabcrashreporter command.  The log entry will look something like: 

LINUX:

Launching tabcrashreporter.exe with the following command: "/var/opt/tableau/tableau_server/data/tabsvc/services/tabadmincontroller_0.20231.23.0511.1508/bin/tabcrashreporter" --command send-logs --source Server --config-file "/var/opt/tableau/tableau_server/data/tabsvc/config/tabadmincontroller_0.20231.23.0511.1508/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --type Application --zipped-logs-file "/var/opt/tableau/tableau_server/data/tabsvc/files/log-archives/logs.zip" --client-product-build "20231.23.0511.1508" --client-product-type "Product Server" --client-product-beta "false" --enable-features RemoveDoubleEncryption

WINDOWS:

Launching tabcrashreporter.exe with the following command: "D:/Tableau/Tableau Server/data/tabsvc/services/tabadmincontroller_0.20223.23.0507.0956/bin/tabcrashreporter.exe" --command send-logs --source Server --config-file "D:/Tableau/Tableau Server/data/tabsvc/config/tabadmincontroller_0.20223.23.0507.0956/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --zipped-logs-file "D:\Tableau\Tableau Server\data\tabsvc\files\log-archives\logstest.zip" --client-product-build "20223.23.0507.0956" --client-product-type "Product Server" --client-product-beta "false" --enable-features RemoveDoubleEncryption


3. Strip out the command from the log line and change "--enable-features RemoveDoubleEncryption" to be "--disable-features RemoveDoubleEncryption"
4. In a terminal window: run the resulting command, which should look something like the examples below.  Note that this is ONE very long command, vs. a collection of commands:

LINUX:

"/var/opt/tableau/tableau_server/data/tabsvc/services/tabadmincontroller_0.20231.23.0511.1508/bin/tabcrashreporter" --command send-logs --source Server --config-file "/var/opt/tableau/tableau_server/data/tabsvc/config/tabadmincontroller_0.20231.23.0511.1508/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --type Application --zipped-logs-file "/var/opt/tableau/tableau_server/data/tabsvc/files/log-archives/logs.zip" --client-product-build "20231.23.0511.1508" --client-product-type "Product Server" --client-product-beta "false" --disable-features RemoveDoubleEncryption

WINDOWS:

"D:/Tableau/Tableau Server/data/tabsvc/services/tabadmincontroller_0.20223.23.0507.0956/bin/tabcrashreporter.exe" --command send-logs --source Server --config-file "D:/Tableau/Tableau Server/data/tabsvc/config/tabadmincontroller_0.20223.23.0507.0956/tabcrashreporter.yml" --email myemail@example.com --support-case-number 09999999 --zipped-logs-file "D:\Tableau\Tableau Server\data\tabsvc\files\log-archives\logstest.zip" --client-product-build "20223.23.0507.0956" --client-product-type "Product Server" --client-product-beta "false" --disable-features RemoveDoubleEncryption
 

 

Cause

This issue is under investigation and viewable from the Salesforce Known Issue website under Reference ID W-13073139.
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