KNOWLEDGE BASE

Login failed due to username is case sensitive in Tableau Server 2022.1 with Local Identity Store


Published: 21 Apr 2022
Last Modified Date: 01 Jun 2022

Issue

After upgrading a Tableau Server using Local Identity Store to version 2022.1.0, when logging in, users may receive an error that they have not specified a valid username, even though they are entering exactly the same username that worked prior to upgrading Tableau Server.

The correct behavior is that username should NOT be case-sensitive. If there was an Local Identity Store account with the ID of "UserName" then any of the following variations: "Username" "USERNAME" and "username" should be accepted as valid. But due to this defect it may be the case that only "UserName" actually works. 

Environment

  • Tableau Server 2022.1.0
  • Local Identity Store

Resolution

Option 1

Upgrade to Tableau Server 2022.1.2 


Option 2

As a workaround:
  • Log in using the correct case for the username, if known 
  • If the correct case for username is not known, ask your Tableau Server administrator to look up your username, including case sensitivity.  

Cause

This is a known issue that is fixed in more recent version of Tableau Server.
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