KNOWLEDGE BASE

LBLM Intermittent Activation Failure Occurs in a Multi-Node Installation of Tableau Server


Published: 19 Nov 2021
Last Modified Date: 02 Jun 2022

Issue

When activating LBLM on Tableau Desktop or Tableau Prep using Tableau Server on-premise, the following error can occur intermittently when the Application Server ("Vizportal") process is not located on the initial node, or is located on multiple nodes:

'Unable to activate by signing in. The Tableau license server at https://atr.licensing.tableau.com/443 returned an error. If the issue persists contact Tableau Support.'

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Environment

  • Tableau Server & Tableau Desktop v2020.4 through v2021.3
  • Multi-node Tableau Server Environment
  • Login Based License Management (LBLM)

Resolution

This is a known issue that is fixed in versions 2021.4 and later of Tableau Server and Tableau Desktop. To resolve this issue, upgrade to v2021.4 or higher.

If an upgrade is not feasible, the following workaround options are available to temporarily mitigate the issue:

Option 1:

Adjust Tableau Server topology to ensure that all Application Server ("Vizportal") processes are located only on the initial node.

Option 2: 

Set up a second Tableau Server specifically for LBLM activation, where all Vizportal processes are located on the initial node. 

Cause

Typically, the Application Server (VizPortal) process oversees the Login Based License Management (LBLM) licensing functionality via Tableau Server. If the Application Server process is not located on the initial node, or is located on multiple nodes, an error can arise while activating via Tableau Desktop in a multi-node environment due to a known issue.
 

Additional Information

To identify this issue by its intermittent nature:

When Tableau Desktop is activated through LBLM, the request goes through the Tableau Server Gateway and Vizportal processes. In an environment where Vizportal processes are not exclusively located on the initial node (where the Activation Service is located), LBLM activations may intermittently fail due to the request going through one of the other nodes, but the request will succeed when it goes through the same node as the Activation Service.

In the logs of a 3-node environment with a Vizportal process on each node, this would look like the following:

Vizportal on node1, from a the vizportal_node1-0.log file shows an http status of 200 (ok) for this request: 
 
Request completed: /api/clientxml/license/identity/requestauthorizationtorun with status 200

Vizportal on node2, from a the vizportal_node2-0.log file shows a 500 status: 
 
Request completed: /api/clientxml/license/identity/requestauthorizationtorun with status 500

Vizportal on node3, from a the vizportal_node3-0.log file also shows the 500 status: 
 
Request completed: /api/clientxml/license/identity/requestauthorizationtorun with status 500
 

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