KNOWLEDGE BASE

Infinite Loading Spinner or Extract Creation Dialog After Authenticating to LinkedIn with InMail Engagment Starter Workbook


Published: 13 Apr 2021
Last Modified Date: 19 Apr 2021

Issue

After opening the InMail Engagement workbook from Dashboard Starters and authenticating with your own LinkedIn credentials, one of two things happens:

  • The extract creation dialog continues indefinitely until cancelled.
  • Clicking "Update Now" in the data preview pane results in an infinite spinner and the data never loads.

Environment

  • Tableau Desktop
  • InMail Engagement starter workbook
  • LinkedIn Sales Navigator connection

Resolution

Ensure that you have a Sales Navigator Enterprise plan and Sales Navigator administrator or reporting permissions. These are requirements for the LinkedIn Sales Navigator connection.

Cause

User does not have a Sales Navigator Enterprise plan, or does not have Sales Navigator administrator or reporting permissions. This can be confirmed by attempting to create a fresh LinkedIn Sales Navigator connection. If the user does not have an enterprise plan, the Connect button will be grayed out.
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