ナレッジベース

Google Analytics 抽出とポータル番号が一致しない


発行: 14 May 2013
最終修正日: 07 Oct 2019

問題

Google Analytics によるレポートを同じデータ ソースに接続された Tableau Desktop で使用できるデータと比較すると、Google Analytics で抽出される数値は、Google Analytics ポータルの数値とは異なることがわかります。

環境

  • Tableau Desktop
  • Google Analytics

解決策

Google Analytics から取得する複数のレポートを一致させるには、同じ詳細レベルのデータ接続 (ディメンションとインポートするメジャー) を Google Analytics レポートに使用するように構成します。

  • [セッション] の正しい結果を取得するには、すべてのイベント関連ディメンションをクエリから削除する必要があります。
  • [ユニーク イベント数] の正しい結果を取得するには、すべてのイベント関連ディメンションをクエリに含める必要があります。
  • [ユニーク ユーザー] の正しい結果を取得するには、すべてのセッションまたはイベント関連のディメンションをクエリから削除します。さらに、"Date (日付)" ディメンションと、"Year (年)" またはデータを分割しない他のディメンションのクエリを除外します。
これは、Google Analytics への個別の接続を作成して、必須となる異なるレベルのデータを取得する必要があることを意味します。

原因

[ユニーク ユーザー] などのフィールドは、不一致の原因となる接続ではディメンションのセットごとに計算されます。

Google Analytics は、多くの点で、サポートされている他のデータ ソースとは異なります。主な違いの 1 つは、Google Analytics はある程度集約済みのデータを Tableau に提供するという点です。これにより、ユニークな訪問など、非集計関数の問題が発生する場合があります。Tableau は日付ごとのユニークな訪問に基づいた数を使用しますが、複数の日付に訪問する同じユーザーと、1 度だけ訪問するユーザーを区別することはできません。
 

詳細情報

Tableau Desktop では、レポートをミラーリングできない場合がよくあります。これは、Google Analytics でレポートを作成するために使用される情報と情報レベルに関する詳細のすべてが常に外部利用できるわけではないという事実に起因します。Google から提供されている次のツールを使用すると、利用可能なデータについてより深く調べることができます。


結果がまだ同一にならない場合は、Google Analytics から未加工のデータをインポートし、結果を Tableau Desktop で Google Analytics からインポートしたデータと比較します。

Google のユーザー メトリックから情報を取得する詳細については、次を参照してください。

この記事で問題は解決しましたか?