KNOWLEDGE BASE

Gateway Service Does not Start and Tableau Server is Degraded


Published: 19 Jul 2018
Last Modified Date: 09 May 2023

Issue

The Gateway Service does not start and Tableau Server is degraded.  This issue can appear after a Tableau Server restart or due to unexpected down time.

 When issuing the command, "tsm status -v", the output includes the following:
Status: DEGRADED 
'Tableau Server Gateway 0' is in an error state. 
 
Gateway logs can show a problem with port 80 or 443 as follows:

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address [::]:443

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : AH00072: make_sock: could not bind to address [::]:80

 

Environment

  • Tableau Server 

Resolution

Option 1

If the Server had unexpected downtime, the httpd.pid file can exist when normally it is removed on shutdown.  Please review the following information to determine if this option is applicable.

Check the startup.log in httpd for the following log item:
httpd (pid <number>) already running

Although the Gateway process is not running, there is an existing httpd.pid in <tableau_server_data_directory>/tabsvc/logs/httpd/ 

Please note: It is possible to check the environment variables to find the correct location of the tabsvc/logs/httpd folder such as $TABLEAU_SERVER_DATA_DIR and $TABLEAU_SERVER_DATA_DIR_VERSION.

Perform the following:
  1. Stop the server using TSM stop.
  2. Linux:  Locate the httpd.pid in <tableau_server_data_directory>/tabsvc/logs/httpd/ 
    Windows:  Locate the httpd.pid in <tableau_server_data_directory>\tabsvc\logs\httpd
  3. Manually remove the httpd.pid file. 
  4. Run TSM start to start Tableau Server and use "tsm status -v -u <username>" to confirm the gateway service is up and running.

Option 2

There is a port conflict issue.

Because IIS and Tableau Server's gateway service can both occupy port 80 after a restart or Windows update, remove IIS from the Tableau Server machine or reassign ports.  The "netstat -anob" command can be run to see the ports currently in use and what PID is bound to port 80.  A PID of 4 is typically IIS.

For more information on errors due to other services running on port 80, please see this additional article.

If SSL is enabled, the Gateway process can be in an error state when port 443 is occupied by another process.
 

Cause

There are several root causes to this issue with some being:
  • Due to unexpected Tableau Server downtime, the httpd.pid file, which is generally removed on shutdown, was not removed.
  • Tableau Server was restarted or Windows maintenance performed that auto activated IIS using port 80 or 443 with SSL.
  • Port 80 is taken up by another process.

 
Did this article resolve the issue?