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Failed to connect to TabPy


Published: 23 Apr 2021
Last Modified Date: 27 Apr 2021

Issue

When testing TabPy connection on Tableau Desktop Or when trying to open the published workbook, the following error occurs :

  • "Failed to connect to analytics extension: An error occurred while communicating with the analytics extension. Tableau is unable to connect to the extension. Verify that the extension is running and that you have access privileges"

Environment

  • Tableau Server 2020.3.1
  • Windows 10

Resolution

Disable the checkbox for "Require SSL" in Tableau Server setting. 
This error may occur if 'SSL configuration' is incorrect. For example, if 'Require SSL' box is checked in the setting page on either Tableau Server or Tableau Desktop when SSL is not configured for TabPy, the test connection on Tableau Desktop would fail with the same error message above. 
 

Cause

'Require SSL' was checked on the Settings > Extensions page on Tableau Server even though SSL for TabPy was not configured.

Additional Information

TabPy can run on the same machine as Tableau Server. However, even if external SSL is enabled for Tableau Server, this does not guarantee that SSL is configured for the analytics extension.
Please verify if SSL is configured for analytics extension by checking 
  1.  The certificate must be trusted by the computer running Tableau Server.
  2. The certificate Subject field or one of the SAN entries on must exactly match the URI of the analytics extensions service configuration.
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