KNOWLEDGE BASE

Extract Refresh Button On Data Source Page Not Running Refresh


Published: 21 Feb 2019
Last Modified Date: 22 Apr 2019

Issue

When attempting to refresh an extract in Tableau Desktop by using the Refresh button in the upper right-hand side of the Data Source tab under the Connection header, nothing appears to happen and the Date/Time for the extract does not update.

Environment

  • Tableau Desktop 10.5.12 - 10.5.13, 2019.1.0, 2018.3.3, 2018.2.7, 2018.2.6, 2018.1.9

Resolution

Workaround:
 
Option 1:
  • Upgrade to March 26th 2019 versions of Tableau
Option 2:
  • On a Dashboard, navigate to the Data at the top toolbar, and select Refresh All Extracts.
Option 3:
  • Run the refresh for the extract from the Data menu from one of the individual worksheets (Data -> <extract name> -> Extract -> Refresh)
Option 4: 
  • Install a previous version of Tableau Desktop (for example, 2018.3.2).

Cause

Related to known issue ID # 877609 which was fixed in March 26th 2019 releases
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