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Export Crosstab to Excel Fails When Excel is Already Open


Published: 01 Feb 2018
Last Modified Date: 25 May 2018

Issue

When exporting a crosstab to Excel from Tableau Desktop while an instance of Excel is already running, an error might occur:

Error sending crosstab to Excel

Environment

  • Tableau Desktop 
  • Windows
  • Excel

Resolution

To resolve this issue, follow these steps: 
  1. Temporarily disable any security features within Excel that may be causing this error 
  2. Ensure that all the open Excel instances are in “Ready” mode. 
Please refer to this link for more information: Excel status bar options 


 

Cause

The error indicated is actually caused by Excel, and is typically caused when an antivirus or security based Excel plug-in shuts down access to DCOM ports. Additionally, when Microsoft Excel is in Enter/Edit/Point mode, DCOM ports are in use and therefore Tableau Desktop is prevented from accessing them. 
 

Additional Information

If the same operation is performed while Excel is not open, the export completes with no errors.
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