KNOWLEDGE BASE

Errors "Unable to connect" or "Malformed response" Connecting to Published Datasource with OAuth Authentication


Published: 06 May 2019
Last Modified Date: 22 May 2019

Issue

When connecting to a published datasource which has been configured to prompt the user for credentials via OAuth, one of the following errors might occur:

An error occurred while communicating with Tableau Server

Or

Error: Unable to connect to this Tableau server data source.

Or

Malformed Response from Tableau Data Server

Environment

  • Tableau Desktop 2018.2.8, 2018.2.9, 2018.3.5, 2018.3.6, 2019.1.2 and 2019.1.3
  • Published datasource using OAuth authentication*

Cause

This behavior is related to a known issue with ID 905687 which has been fixed in a recent version of Tableau Destop.

Additional Information

*The following data sources (which can use OAuth) might be affected: 
  • Salesforce
  • Google BigQuery
  • Google Analytics
  • Google Sheets
  • QBO (QuickBooks Online)
  • Eloqua
  • ServiceNow
  • AdWords
  • Box
  • OneDrive
  • DropBox
  • Snowflake
  • WDC (as most web data connector use OAuth)
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