BASE DE CONNAISSANCES

Erreurs « Setting site role for user to '<siterole>' failed » ou « Insufficient licenses. Setting user roles to '<siterole>' failed. »


Date de publication : 11 Mar 2016
Date de dernière modification : 29 Sep 2021

Problème

Lors de la tentative d'ajout d'un nouvel utilisateur ou de l'affectation d'un rôle sur le site à un utilisateur sur Tableau Server, l'un des messages d'erreur suivants peut s'afficher :

Setting site role for user <username> to '<siterole>' failed
Ou 
Insufficient licenses. Setting user roles to '<siterole>' failed.
Ou
Exceeds limit for '<siterole>' role.

Environnement

  • Tableau Server
  • Tableau Online

Résolution

Tableau Online

  1. Connectez-vous à Tableau Online en tant qu’administrateur de site et, depuis la page Utilisateurs, vérifiez le nombre total de postes disponibles pour chaque rôle sur le site (pour chaque type de rôle sur le site, le chiffre de droite est le nombre de licences achetées sur votre site pour le rôle ; le chiffre de gauche est le nombre d’utilisateurs auxquels le rôle est actuellement attribué).
  2. Si un rôle donné sur le site dépasse la limite, convertissez les utilisateurs existants vers le rôle souhaité ou annulez la licence de certains utilisateurs afin de libérer des postes pour le rôle souhaité sur le site.



Tableau Server sur Windows 2018.2 et versions ultérieures, Tableau Server sur Linux 

  1. Vérifiez que toutes les clés produit ont été activées en accédant au Portail client Tableau et en sélectionnant le rapport « Clés - Serveur uniquement ».  Exécutez la commande TSM Licenses List pour comparer les clés activées avec le rapport sur les clés totales.  Pour plus d’informations sur l'ajout de clés produit, consultez Ajouter de la capacité à Tableau Server.
  2. Vérifiez que toutes les clés produit sont actualisées avec une date de maintenance active. Pour plus d'informations, consultez Actualiser la date de maintenance pour la clé produit
  3. Redémarrez Tableau Server à l'aide des commandes suivantes pour synchroniser Tableau Server avec Trusted Storage.
  4. Ouvrez une invite de commande en tant qu'administrateur, puis accédez au dossier bin de Tableau Server, qui se trouve par défaut à l'adresse C:\Program Files\Tableau\Tableau Server\packages\bin.<version> sur Windows ou /opt/tableau/tableau_server/packages/bin.<version> sur Linux.
tsm stop
lmreread
tsm start

Dans un environnement Tableau Server multisite : 

Si Tableau Server reflète le nombre correct de licences disponibles sur un site individuel, mais n'est toujours pas disponible pour ajouter un nouvel utilisateur :
  1. Sélectionnez Gérer tous les sites et vérifiez la liste complète des utilisateurs.
  2. Vérifiez que le nombre d'utilisateurs sur tous les sites ne dépasse pas le nombre de postes de licence. 
 

Tableau Server sur Windows 2018.1 et versions antérieures

  1. Vérifiez que toutes les clés Interactor sont activées dans Gérer les clés produit. Pour plus d'informations, consultez Ajouter de la capacité à Tableau Server.
  2. Assurez-vous que toutes les clés Interactor sont actualisées avec une date de maintenance active. Pour plus d'informations, consultez Actualiser la date de maintenance pour la clé produit
  3. Redémarrez Tableau Server à l'aide des commandes suivantes pour synchroniser Tableau Server avec Trusted Storage.
  4. Ouvrez une invite de commande en tant qu'administrateur, puis accédez au dossier bin de Tableau Server, qui se trouve par défaut à l'adresse C:\Program Files\Tableau\Tableau Server\[Version]\bin.
tabadmin stop
lmreread
tabadmin start

Dans un environnement Tableau Server multisite : 

Si Tableau Server reflète le nombre correct de licences disponibles sur un site individuel, mais n'est toujours pas disponible pour ajouter un nouvel utilisateur :
  1. Sélectionnez Gérer tous les sites et vérifiez la liste complète des utilisateurs.
  2. Vérifiez que le nombre d'utilisateurs sur tous les sites ne dépasse pas le nombre de postes de licence. 


 

Cause

Lorsque vous tentez d'ajouter un nouvel utilisateur ou d'affecter un rôle sur le site à un utilisateur sur Tableau Server, l'environnement Tableau Server a atteint ou dépassé le nombre total de postes disponibles.

Informations supplémentaires

Vérifiez le nombre de postes attribués pour déterminer si le rôle Explorer est en surcapacité et prend ainsi le rôle Creator disponible.  Les licences Creator peuvent être utilisées pour remplir le rôle Explorer et les postes Explorer peuvent être utilisés pour remplir le rôle Viewer. Les postes Creator ne peuvent pas être utilisés pour remplir le rôle Viewer.

Discuter de cet article... Forum de commentaires
Cet article vous a-t-il permis de résoudre le problème ?