BASE DE CONNAISSANCES

Erreurs "Setting site role for user to '<siterole>' failed" ou "Insufficient licenses. Setting user roles to '<siterole>' failed."


Date de publication : 11 Mar 2016
Date de dernière modification : 15 Jul 2020

Problème

Lors de la tentative d'ajout d'un nouvel utilisateur ou de l'affectation d'un rôle sur le site à un utilisateur sur Tableau Server, l'un des messages d'erreur suivants peut s'afficher :

Setting site role for user <username> to '<siterole>' failed (La définition du rôle sur le site pour l'utilisateur <nom d'utilisateur> sur '<siterole>' a échoué)
Ou 
Insufficient licenses. Setting user roles to '<siterole>' failed. (Licences insuffisantes. La définition des rôles utilisateur sur '<siterole>' a échoué.)

Environnement

Tableau Server

Résolution

Tableau Server sur Windows 2018.2 et versions plus récentes, Tableau Server sur Linux 

  1. Vérifiez que toutes les clés produit ont été activées en accédant au Portail client Tableau et en sélectionnant le rapport « Clés - Serveur uniquement ».  Exécutez la commande TSM Licenses List pour comparer les clés activées avec le rapport sur les clés totales.  Pour des informations sur l'ajout de clés produit, consultez Ajouter de la capacité à Tableau Server.
  2. Vérifiez que toutes les clés produit sont actualisées avec une date de maintenance active. Pour plus d'informations, consultez Actualiser la date de maintenance pour la clé produit.
  3. Redémarrez Tableau Server à l'aide des commandes suivantes pour synchroniser Tableau Server avec Trusted Storage.
  4. WindowsOuvrez une invite de commande en tant qu'administrateur, puis accédez au dossier bin de Tableau Server, qui se trouve par défaut à l'adresse C:\Program Files\Tableau\Tableau Server\packages\bin.<version> sur Windows ou /opt/tableau/tableau_server/packages/bin.<version> sur Linux.
tsm stop
lmreread
tsm start

Dans un environnement Tableau Server multisite : 

Si Tableau Server reflète le nombre correct de licences disponibles sur un site individuel, mais n'est toujours pas disponible pour ajouter un nouvel utilisateur :
  1. Sélectionnez Gérer tous les sites et vérifiez la liste complète des utilisateurs.
  2. Vérifiez que le nombre d'utilisateurs sur tous les sites ne dépasse pas le nombre de postes de licence.
 

Tableau Server sur Windows 2018.1 et versions antérieures

  1. Vérifiez que toutes les clés Interactor sont activées dans Gérer les clés produit. Pour plus d'informations, consultez Ajouter de la capacité à Tableau Server.
  2. Assurez-vous que toutes les clés Interactor sont actualisées avec une date de maintenance active. Pour plus d'informations, consultez Actualiser la date de maintenance pour la clé produit.
  3. Redémarrez Tableau Server à l'aide des commandes suivantes pour synchroniser Tableau Server avec Trusted Storage.
  4. Ouvrez une invite de commande en tant qu'administrateur, puis accédez au dossier bin de Tableau Server, qui se trouve par défaut à l'adresse C:\Program Files\Tableau\Tableau Server\[Version]\bin.
tabadmin stop
lmreread
tabadmin start

Dans un environnement Tableau Server multisite : 

Si Tableau Server reflète le nombre correct de licences disponibles sur un site individuel, mais n'est toujours pas disponible pour ajouter un nouvel utilisateur :
  1. Sélectionnez Gérer tous les sites et vérifiez la liste complète des utilisateurs.
  2. Vérifiez que le nombre d'utilisateurs sur tous les sites ne dépasse pas le nombre de postes de licence.


 

Cause

Lorsque vous tentez d'ajouter un nouvel utilisateur ou d'affecter un rôle sur le site à un utilisateur sur Tableau Server, l'environnement Tableau Server a atteint ou dépassé le nombre total de postes Interactor disponibles.
Cet article vous a-t-il permis de résoudre le problème ?