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Errors "Reconnect to data source" and "HTTP Bad request" When Attempting to Connect to a Data Source (such as Salesforce)


Published: 09 Mar 2018
Last Modified Date: 20 Jun 2018

Issue

In Tableau Desktop, after connecting to a data source (e.g. Salesforce) the following error message might occur after attempting to perform the following actions:

Reconnect to <data source name (...)>
 
  • Publishing the data source to Tableau Server or Tableau Online
  • Swapping connection to use the published data source
  • Navigating to sheet 1
  • Placing any field in the view
Additionally, after clicking "No" in the error message pop-up, the following error will appear: 

An error occurred while communicating with data source "data source name (...)". 
The connection to the data source might have been lost. 

After click the Show Details option, the following message will appear: 

HTTP bad request (...)

 

Environment

  • Tableau Desktop 10.0 and later versions
  • Tableau Server
  • Windows 7
  • Salesforce.com

Resolution

Option 1

Upgrade to Tableau Desktop 2018.1.2, 10.5.5, 10.4.8, 10.3.12 or a later version. For more information, see Upgrading Tableau Desktop in Tableau Help.

Option 2

As a workaround, navigate to the sheet 1, forcing Tableau Desktop to create the extract. Then publish the data source and it will function as expected.

Cause

This behavior is related to a known issue (ID: 749962) which has been fixed in recent releases of Tableau Desktop. 
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