KNOWLEDGE BASE

Errors Are Displayed When Users Visit the Extensions Settings Page


Published: 01 Dec 2018
Last Modified Date: 13 Feb 2019

Issue

Errors are displayed when visiting the Extensions Settings Page, and the Extension zones are blank when a viz is rendered.

Environment

  • Tableau Desktop
  • Tableau Server

Resolution

This behavior is caused by a known issue, ID 831047, which has been corrected in Tableau Desktop and Tableau Server version 2019.1 and later.

Option 1

Upgrade to Tableau Desktop or Tableau Server version 2019.1 or later. For more information, see Upgrade Tableau Desktop, or Upgrade Tableau Server Overview.

If you cannot upgrade to the version where the defect has been resolved, try one of the following workaround options:

Option 2: Create a new site

Create a new site and visit the Extension Site Settings page before opening any dashboards with Extensions. Visiting the Extension Site Settings page the first time properly sets up the site for Extensions.

Option 3: SQL Statement

Run the following SQL statement against the database used for the dashboard to remove the duplicate records in the database table.
 
DELETE FROM extensions_site_settings
WHERE site_id in (
    SELECT site_id
    FROM extensions_site_settings
    WHERE active=true
    GROUP BY site_id
    HAVING COUNT(*) > 1
);

 
Once the extension is setup correctly, this issue will not happen anymore and you can open workbooks with as many extensions as you want.

Cause

This behavior is caused by a known issue, ID 831047, which has been corrected in Tableau Desktop and Server version 2019.1 and later.
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