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Errors "An error occurred while communicating with Excel Reader" When Connecting to Excel Workbook in Tableau Desktop


Published: 25 Jan 2018
Last Modified Date: 23 Aug 2019

Issue

When attempting to connect to an Excel file saved as a "Strict Open XML Spreadsheet" file type using the standard Excel connector, an unexpected error occurs. The following additional behaviors may also occur depending on your Tableau Desktop version: 

Tableau Desktop 10.0-10.1
The below error runs indefinitely
 
"Executing query"
 
but ultimately ends in
 
"Failed to Connect to database".

Tableau Desktop 10.2-10.5 
The connection immediately fails with
 
"An error occurred while communicating with Excel Reader.
Unable to connect to the Excel file. It might be corrupt.
Try opening the file in Excel, saving it under a new name, and then connecting from Tableau again."

Environment

  • Tableau Desktop
  • Windows
  • Excel

Resolution

Try one of the following options:

Option 1

Save the Excel .xlsx file as a "Excel Workbook" file type (File > Save As > Save As Type: in Excel)

Option 2

Connect to the file using the Open with Legacy Connection option in Tableau Desktop. (See note in Additional Information)

Cause

Tableau Desktop is unable to connect to Excel workbooks (.xlsx files) saved as a "Strict Open XML Spreadsheet" file type.

Additional Information

Note: Starting in Tableau 2019.1, you can no longer create a new Legacy Excel or Text connection. Existing workbooks created with these legacy connections will continue to work until 2019.2, when all support for legacy connections will be removed. See the Legacy Connection Alternatives document in Tableau Community for alternatives to using the legacy connection.



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