KNOWLEDGE BASE

Error: "Your session timed out. Reopen the dialog to connect" when using Tableau Desktop to view Published Data Sources on Tableau Server


Published: 04 Nov 2022
Last Modified Date: 01 Feb 2023

Issue

When attempting to view published data sources on Tableau Server through the "Connect to Data" option in Tableau Desktop, the request fails with error message:

Your session timed out. Reopen the dialog to connect.

Environment

  • Tableau Server
  • Tableau Desktop version 2022.2, 2022.3 and newer

Resolution

  1. Upgrade Tableau Desktop to version 2022.2.6 or 2022.3.3 that was published during the January 2023 maintenance release.
  2. If it is not possible to upgrade Tableau Desktop, issue the following to use the Chrome flag:
 
C:\Program Files\Tableau\Tableau 2022.3\bin>tableau.exe --disable-features=SameSiteByDefaultCookies

Cause

This issue has been resolved under ID 1470508.  See the Release Notes for Tableau Desktop in 2022.3.3 and 2022.2.6.  

Additional Information

Because there was no 2022.4 Tableau Desktop update in the January 2023 maintenance release, to receive this fix for 2022.4, upgrade to 2022.4.1 due out in the February maintenance release.  Release Notes and downloads are available here.
Did this article resolve the issue?