KNOWLEDGE BASE

Error "Your Computer’s Processor Doesn’t Meet The Minimum Requirements That Tableau Requires To Install The Software" In VM Environment


Published: 16 Feb 2021
Last Modified Date: 08 Jul 2022

Issue

When installing or updating 2020.4+ versions of Tableau products on a virtual machine with "Processor Compatibility Mode" enabled will result in the error:

Your computer’s processor doesn’t meet the minimum requirements that Tableau requires to install the software.

Environment

  • All Tableau products
  • Virtual Machine Environment

Resolution

If using Microsoft Hyper-V, disable the Processor Compatibility Mode for the VM.

If using VMWare, enable Enhanced vMotion Compatibility (EVC) and set the EVC baseline to at least Intel® Nehalem (L2) or AMD Opteron™ Generation 4 (B1).
 

Cause

VMs in processor compatibility mode do not support modern CPU instructions. Modern means more than a decade ago.

Additional Information

With 2020.4, Tableau changed its minimal hardware requirements to CPUs that have at least the SSE4.2 and POPCNT instructions (see announcement here: https://www.tableau.com/about/blog/2020/4/helping-you-have-fast-tableau-experience-130832). This only affects very old hardware. However, when a VM is using "processor compatibility mode" (or "CPU compatibility mode") set, they will also run into this issue as the VM simulates a very old CPU instruction set despite the actual hardware would actually support it.
Did this article resolve the issue?