KNOWLEDGE BASE

Error: “Uncaught Failed to re-initialize session” or “Lost Connection to Tableau” when embedding a Tableau Server view in another application


Published: 19 Jan 2024
Last Modified Date: 19 Jan 2024

Issue

When embedding a view, the view may fail to load with this error message “Uncaught Failed to re-initialize session” 

Alternatively, the view may briefly render but then fail with error message: “Lost Connection to Tableau” 



 

Environment

  • Tableau Server
  • Embedded Views
  • Dynatrace (3rd Party Monitoring)

Resolution

To resolve this issue, configure Dynatrace to not interfere with the HTTP request or response headers that Tableau Server uses to communicate with the application that it is embedded in.

 

Cause

A third party tool, Dynatrace, is interfering with the HTTP requests that Tableau is sending and receiving. 

Additional Information

Identifying this issue from log review: Dynatrace entities will be visible throughout Tableau Server's process logs. 

The below example is pulled from an access log (from Tableau's Gateway/httpd process). Observe the 410 response for this request and the dt.entity, dt.trace and other dt.* entries in the log line. These entities are from Dynatrace injecting itself into Tableau's HTTP layer, resulting in a mangled authentication session id and request.

2024-01-03T11:44:39.728 "-0700" 443 "POST /vizql/w/Workbookname/v/Viewname/bootstrapSession/sessions/9EAACD529B34431CB2142074508C612A-5:0 HTTP/1.1" "<IP>" 410 - "1178" 13336 ZZWrFzE0ioTVvp4Ta_khiwAAACk NeedsClassification 2 0xE3C7443A Unknown_Service "-" [!dt dt.entity.host=HOSTNAME ,dt.entity.process_group_instance=PROCESS_GROUP_INSTANCE-1A61854BA4377942,dt.trace_id=7af739e27bee0313944daf531ca9a102,dt.span_id=d3f503126bef790b,dt.trace_sampled=false] [!dt dt.entity.host=HOSTNAME ,dt.entity.process_group_instance=PROCESS_GROUP_INSTANCE-1A61854BA4377942,dt.trace_id=7af739e27bee0313944daf531ca9a102,dt.span_id=d3f503126bef790b,dt.trace_sampled=false] [!dt dt.entity.host=HOSTNAME ,dt.entity.process_group_instance=PROCESS_GROUP_INSTANCE-1A61854BA4377942,dt.trace_id=7af739e27bee0313944daf531ca9a102,dt.span_id=d3f503126bef790b,dt.trace_sampled=false]


Note that Dynatrace is not the only third party monitoring tool that can result in these error messages; however Dynatrace has a particular style of logging that shows clearly in the logs for Tableau processes. The underlying issue is that any 3rd party monitoring tool not configured to preserve Tableau's http request/response headers can cause 410 responses for embedded views with either/both of these error messages in Tableau's HTTP(Apache, Gateway) process. 

For more information on how Tableau Server http requests are passed through intermediary network tools, such as embedding in applications and also when using proxies and load balancers, see the following sections of the Tableau product guide:

Configuring Proxies and Load Balancers for Tableau Server
Add a Load Balancer
Embed Views into Salesforce
Tableau Embedding API: Authentication and Embedded Views
Communicating with the Internet


 

Did this article resolve the issue?