KNOWLEDGE BASE

Error "Unable to verify the server's HTTPS certificate" When Logging in with TSM Command


Published: 24 Apr 2018
Last Modified Date: 03 Apr 2023

Issue

When trying to login with the command: tsm login -u <username> -s <server> the following error message might occur: 

Unable to verify the server's HTTPS certificate

Environment

  • Tableau Server 
  • Linux
  • Windows

Resolution

Ensure the CN name from the TLS Certificate is matched to the host name machine. The following commands determine if the hostname matches with the CN from the TLS certificate :

Linux: 

1. To display the hostname, issue the command "hostnamectl".

2. To display the TLS certificate, issue the following:

echo | openssl s_client -servername <serverName> -connect 127.0.0.1:8850 2>/dev/null | openssl x509 -text

Note: openssl is located in the installed location typically: /opt/tableau/tableau_server/packages/apache<version>/bin

3. To edit the hostname issue the following command:
sudo hostnamectl set-hostname "myHostname" --static

Windows
Via the Control Panel, select System and Security > System > Change settings to see the Computer name, domain and workgroup settings.

 

Cause

Tableau Server installation process uses the computer’s host name to configure server processes and generate TLS certificates. The CN name from the TLS Certificate is different than the host name machine.

 
Did this article resolve the issue?