KNOWLEDGE BASE

Error "Unable to resolve database file path: Directory does not exist" When Accessing Extracts in OneDrive Folders


Published: 18 Apr 2018
Last Modified Date: 09 Jul 2018

Issue

When saving or accessing extracts in OneDrive folders, the following error may occur:
[-10] PQresultStatus: 7 ERROR: Unable to resolve database file path: Directory does not exist [SQL State: 58P01] [Severity: ERROR] [Primary message: Unable to resolve database file path: Directory does not exist]
Unable to create extract

Environment

  • Tableau Desktop 10.5
  • Windows 10
  • Extract files stored in OneDrive folders

Resolution

  1. Right click the OneDrive icon in the System Tray
  2. Select Settings
  3. Go to the Settings tab
  4. Uncheck the Files on Demand setting

Cause

With Files on Demand enabled with OneDrive, the files and folders are not stored locally unless they are opened in an application. The error occurs since the files do not exist locally, when Tableau Desktop checks for their existence before opening them, Windows reports back that the files are not there.
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